android原生项目集成easyar untiy版本出现invalid key or package错误,key和bundle Identifier没错,发布的apk不出错

+1 投票
最新提问 1月 25, 2018 用户: yydjtcy (840 分)
如题,用easyar+unity做了一个demo,检查了key和bundle Identifier都没问题,跟网站的一致。调试和打包成android  apk在手机上安装运行也都没问题。但是发布成Google Android System后集成在另一个原生android项目中运行就提示“invalid key or package”错误了。key什么的都没问题的,打包的apk也没问题,就是集成到别的android工程中就出这个错误了,求解答,万分感谢!

3 个回答

0 投票
最新回答 1月 29, 2018 用户: xlwarworld (1,840 分)
有可能是因为代码混淆的原因。
0 投票
最新回答 9月 16, 2018 用户: junglewolf (220 分)
这个估计是因为EasyAR在检查key和bundle Identifier的时候,本来希望使用原来的bundle Identifier,但是最后得到的是外层应用的bundle Identifier。我觉得可以试试重新申请一个应用,然后将bundle Identifier改为外层应用的,不一定有用,额。。都9月份了。。
0 投票
最新回答 9月 1 用户: zhangjun (290 分)
请问这个问题解决了吗?忘百忙之中回复一下,多谢
欢迎来到 EasyAR Q&A ,有什么不懂的可以尽管在这里提问,你将会收到社区其他成员的回答。
...