社区案例HelloARVideo,安卓手机识别只有黑色的plane和声音没有画面

+1 投票
最新提问 12月 18, 2018 用户: mashirocl (160 分)
如题,我没有改动样例,样例用的是官网最新的,在手机上识别普通视频那个只有黑色的plane和声音没有画面,透明视频那个只有黑色的sphere。 有声音所以我觉得视频资源肯定是在app里了,识别路径也是正确的,但是为什么没有画面呢

2 个回答

0 投票
最新回答 12月 18, 2018 用户: albert52 (37,640 分)
手机具体型号是多少啊。。。。
发表于 12月 18, 2018 用户: mashirocl (160 分)
您好 手机型号是华为麦芒5
发表于 12月 18, 2018 用户: mashirocl (160 分)
您好 我换了一台vivo手机 情况依然是黑块儿呢。。
发表于 12月 19, 2018 用户: abby5201 (120 分)
你好,请问这个问题您解决了吗?我也遇到了类似 的问题
发表于 12月 19, 2018 用户: mashirocl (160 分)
还没有呢,我估计是unity版本问题,我打算换成unity2017重新打包一次试试
发表于 12月 19, 2018 用户: abby5201 (120 分)
我用的是unity2017.3.0
发表于 12月 19, 2018 用户: mashirocl (160 分)
这。。就很尴尬了。。那我也不清楚具体的原因了,我查这问题查了2天了,毫无进展。。。
发表于 12月 19, 2018 用户: abby5201 (120 分)
我用的是unity2017.3.0,具体描述在这里,你也可以看一下https://answers.easyar.cn/3007/unity-easyar-%E5%9C%A8iphone6p%E4%B8%8A%E6%89%AB%E6%8F%8F%E7%9B%AE%E6%A0%87%E5%9B%BE%E7%89%87%E6%98%BE%E7%A4%BA%E6%A8%A1%E5%9E%8B%E7%B4%A0%E6%9D%90%E4%B8%BA%E9%BB%91%E8%89%B2
发表于 12月 19, 2018 用户: mashirocl (160 分)
我的情况跟你略微不一样,我单纯显示模型是没问题的,但是加载视频的时候会出现显示不了而只出现黑色的plane或sphere
发表于 12月 19, 2018 用户: abby5201 (120 分)
嗯呢,我的模型显示是从外部加载的,模型本身带有移动和缩放的动画的,我怀疑是不是因为这个原因
发表于 12月 19, 2018 用户: mashirocl (160 分)
我看了你那个情况 我觉得有可能,要不你先把动画的部分去掉,单独跑模型看看能不能加载出来?
0 投票
最新回答 12月 26, 2018 用户: wongjm (140 分)
我也遇到了相同的问题,把社区的帖子翻了个底朝天,貌似无解,只能等easyAR 3发布了。
发表于 12月 27, 2018 用户: mashirocl (160 分)
如果是相同的情况的话 可以试试用unity2017  打包的时候选internal 我的就这样解决了
发表于 12月 31, 2018 用户: wongjm (140 分)
我安装了unity 5.6.6,成功的打包成了安卓APP。有空再用untiy2017试一试。谢谢!
欢迎来到 EasyAR Q&A ,有什么不懂的可以尽管在这里提问,你将会收到社区其他成员的回答。
...